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SPECIAL NOTE 

 

Due to the continuous evolution of the CDEGS software, you may find that some of the 

screens obtained using the present version of the CDEGS package are slightly 

different from those appearing in this manual. Furthermore, small differences in the 

reported and plotted numerical values may exist due to continuous enhancements of 

the computation algorithms. 
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INTRODUCTION 

1.1 OBJECTIVE 

The objective of this study is to obtain the electromagnetic fields around a transmission line tower 

and the induced currents on the tower and on a nearby fence. Two different cases are considered. In 

the first, the phase currents on the transmission line are assumed to be unbalanced and in the second 

a fault is assumed to occur near the tower. 

 

The purpose of this study is twofold: 

1. Give an account of the engineering considerations involved in the modeling of a tower, 

especially under fault conditions. 

2. Familiarize the reader with the use of SES software as applied to the solution of this 

problem. 

The engineering program HIFREQ is used for this study. This example also illustrates the use of 

some of the SES input and output processors. 
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1.2 ORGANIZATION OF THE MANUAL 

There are four main sections to this tutorial and the organization is as follows. 

1. Description of the problems being modeled (Chapter 2) 

2. How to prepare the HIFREQ input files (Chapter 3) 

3. How to submit the HIFREQ runs (Chapter 4) 

4. How to extract and display the results from the HIFREQ output files (Chapter 5) 

Chapter 2 focuses on the engineering aspects of the problems (i.e., both the unbalanced currents and 

the fault scenarios). The remainder of the tutorial gives detailed, step by step instructions on how to 

use the software to model those two situations. It also includes some engineering hints. 

1.3 SOFTWARE NOTE 

This tutorial assumes that the reader is using the Windows version of CDEGS. 

1.4 FILE NAMING CONVENTIONS 

It is important to know which input and output files are created by the CDEGS software. All CDEGS 

input and output files have the following naming convention: 

 

XY_JobID.Fnn 

 

where XY is a two-letter abbreviation corresponding to the name of the program which created the 

file or which will read the file as input. The JobID consists of string of characters and numbers that 

is used to label all the files produced during a given CDEGS run. This helps identify the 

corresponding input, computation, results and plot files. The nn are two digits used in the extension 

to indicate the type of file.  

The abbreviations used for the various CDEGS modules are as follows: 

Application Abbreviation  Application Abbreviation 

RESAP RS  FCDIST FC 

MALT MT  HIFREQ HI 

MALZ MZ  FFTSES FT 

TRALIN TR  SICL* SC 

SPLITS SP  CSIRPS* CS 

SESTLC TC  SESEnviroPlus TR 

SESShield LS  SESShield-3D SD 

GRSPLITS-3D SP  ROWCAD RC 

* The SICL module is used internally by the Input Toolbox data entry interface. The CSIRPS 

module is used internally by the Output Toolbox and GRServer – graphics and report 

generating interface. 
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The following four types of files are often used and discussed when a user requests technical support 

for the software:  

 .F05 Command input file (for engineering applications programs). This is a text file that can 

be opened by any text editor (WordPad or Notepad) and can be modified manually by 

experienced users. 

 .F09 Computation results file (for engineering applications programs). This is a text file that 

can be opened by any text editor (WordPad or Notepad).  

 .F21 Computation database file (for engineering applications programs). This is a binary file 

that can only be loaded by the CDEGS software for reports and graphics display.  

 .F33 Computation database file (for engineering applications programs MALZ and HIFREQ 

only). This is a binary file that stores the current distribution to recover. 

For further details on CDEGS file naming conventions and JobID, please consult CDEGS Help 

under Help | Contents | File Naming Conventions.  
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1.5 WORKING DIRECTORY 

A Working Directory is a directory where all input and output files are created. In this tutorial, we 

recommend the following Working Directory: 

 

C: (or D:)\CDEGS Howto\Tower\ 

 

You may prefer to use a different working directory. Either way, you should take note of the full 

path of your working directory before running CDEGS, as you will need this information to follow 

this tutorial. 

1.6 INPUT AND OUTPUT FILES USED IN TUTORIAL 

There are two ways to use this tutorial: by following the instructions to enter all input data manually 

or by loading the input files provided with the tutorial and simply following along. 

All input files used in this tutorial are supplied on your DVD. These files are stored during the 

software installation under documents\Howto\CDEGS\Tower (where documents is the SES software 

documentation directory, e.g., C:\Users\Public\Documents\SES Software\version, and version is the 

version number of your SES Software) Note that this folder is a distinct folder than the SES software 

installation directory, e.g, C:\Program Files\SES Software\version (where version is, again, the 

version number of your SES Software). 

Copying Input Files to Working Directory 

For those who prefer to load the input files into the software and simply follow the tutorial, you can 

copy all of the files from the documents\Howto\CDEGS\Tower directory to your working 

directory. 

After the tutorial has been completed, you may wish to explore the other How To…Engineering 

Manuals which are available as PDF files on the SES Software DVD in the folder \PDF\Howto. 

If the files required for this tutorial are missing or have been modified, you will need to manually 

copy the originals from the SES Software DVD.Both original input and output files can be found in 

the following directories on the SES Software DVD: 

Input Files: Examples\Official\HowTo\CDEGS\Tower\inputs 

Output Files: Examples\Official\HowTo\CDEGS\Tower\outputs 

Note that the files found in both the ‘Inputs’ and the ‘Outputs’ directories should be copied directly 

into the working directory, not into subdirectories of the working directory. 
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DESCRIPTION OF THE PROBLEM BEING 

MODELED 

In this example, the electromagnetic fields around a transmission line tower are calculated under 

fault conditions and under conditions of unbalanced line currents. The current distribution in the 

tower and a nearby fence are also obtained. 

Figure 2.1 shows a 35 m high 525 kV transmission line tower structure and a 12 m  30 m fence 

located 10 m away from the base of the tower. Details of the electromagnetic fields around the tower 

and the currents induced in the fence and the tower are desired. The various components of the 

network are described as follows. 

 

Figure 2.1 Conductor Network Under Study 

The tower: The tower is 35 m high and is made of steel. Since HIFREQ can currently only model 

cylindrical conductors, the tower will be modeled with steel conductors of 1.5 cm radius. Even 

though real tower conductors are usually not cylindrical, this normally does not introduce any 

appreciable distortion in the electromagnetic fields for observation points located at distances greater 

than about 10 to 20 cm away from the conductors. The steel used here has a relative resistivity of 12 
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(with respect to annealed copper) and a relative permeability of 250 (with respect to free space). The 

four vertical legs of the tower structure are driven to a depth of 10 m into the ground. 

The grounding system: The grounding system consists of a 16 m  16 m loop buried at a depth of 

0.5 m and four vertical ground rods which are driven to a depth of 10 m. Copper conductors of 

radius 7 mm are used. A uniform soil with a 100 -m resistivity, a relative permittivity of 1 and 

relative permeability of 1 is assumed. 

The fence: The fence is 12 m  30 m and is 1.5 m high. The frame and poles of the fence consist of a 

steel tube with an inner radius of 1 cm and an outer radius of 2 cm. The cross wires for the fence 

conductors are made of steel with a 3 mm radius. 

The transmission line: Figure 2.1(b) shows a cross section of the transmission line and fence. The 

transmission line phase conductors are 1565 kcmil 36/7 ACSR conductors and the shield wires are 7-

strand, 1.27 cm diameter galvanized high strength steel conductors. The shield wires are connected 

to the tower. 

It is usually not practical to model the entire transmission line for such a study. A major 

consideration is therefore how much of the line should be modeled in order to obtain results with 

sufficient accuracy. The following rule of thumb can be used. Let dclose be the closest distance 

between a given observation point (a point at which the EM fields have to be computed) and the 

transmission line (Figure 2.2) and let dmax be the maximum value of dclose over all observation points. 

Then, the length of line that should be modeled on either side of every observation point is roughly 

10  dmax. 

 

Figure 2.2 Definition of dclose 

In the case at hand, the fence and the profiles are roughly 20 meters below the line and (at the most) 

60 m away from it. This means that dmax is roughly 20 60 632 2   m. In this case, about 400 m of 

the line were modeled on either side of the fence. Note that, in case of doubt, it is always possible to 

model a little more of the transmission line and verify that the results are indeed unaffected. 
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The phase conductors and shield wires modeled are 800 m long along the Y-direction (Figure 

2.1(c)). This length represents two spans with three towers. The span distance is 400 m and the 

center of the tower shown in Figure 2.1 is at Y = 0. Two towers located at Y = 400.0 m and Y = -

400.0 m are represented in a simplified form (two vertical conductors which connect the shield wires 

to their grounding grids). The grounding grids at both ends consist of a single loop of copper wire 

and of 4 vertical ground rods that are driven to a depth of 10 m. The dimensions of the loops are 16 

m  16 m and they are buried at a depth of 0.5 m. 

Two different energization conditions on the phase wires are investigated: (i) 7% unbalanced phase 

currents and (ii) a fault between a phase wire and a shield wire. Table 2.1 and Table 2.2 list the 

currents and scalar potentials of the phase conductors for these energization conditions. During the 

fault condition, a current of 15000 A is injected into Phase A, which is short-circuited to Shield Wire 

#2 at the tower site (Figure 2.1(a)). Phases B and C carry 430 A each since we are assuming a fault 

during light load conditions. 

 

Table 2.1 Currents on the Phase Wires 

 

Table 2.2 Potentials on the Phase Wires 
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HOW TO PREPARE HIFREQ INPUT FILES 

USING SESCAD 

This section describes in detail how to prepare the HIFREQ input file (.F05 extension) using the 

SESCAD program. The SESCAD program allows you to create, modify, and view complex 

grounding networks and aboveground metallic structures visually, in three dimensions. 

Note that HIFREQ input files can also be prepared using the Windows Input Toolbox Mode 

(Appendix A) or Command Input Mode (Appendix B). The engineering input file created by 

SESCAD, as described in this chapter, is shown in Printout B.1 in Appendix B. It can be reloaded 

during subsequent sessions. 

The most important features in preparing the data in SESCAD are explained in Section 3.3, which 

also describes some tricks on how to avoid common input problems. 

3.1 START UP PROCEDURES 

 

 

In the SES Software <Version> group folder, where <Version> is the version number of the 

software, you should see the icons representing Autogrid Pro, AutoGroundDesign, CDEGS, 

Right-of-Way, SESEnviroPlus, SESShield-3D and SESTLC software packages, as well as four 

folders. The Documentation folder contains help documents for various utilities and software 

packages. The Program Folders provides shortcuts to programs, installation and projects folders. 

Click here 
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The System folder allows you to conveniently set up security keys. Various utilities can be found in 

the Tools folder. The main function of each software package and utility is described hereafter.  

SOFTWARE PACKAGES 

 Autogrid Pro provides a simple, integrated environment for carrying out detailed grounding 

studies. This package combines the computational powers of the engineering programs RESAP, 

MALT and FCDIST with a simple, largely automated interface.  

 AutoGroundDesign offers powerful and intelligent functions that help electrical engineers 

design safe grounding installations quickly and efficiently. The time devoted to design a safe and 

also cost-effective grounding grid is minimized by the use of automation techniques and 

appropriate databases. This module can help reduce considerably the time needed to complete a 

grounding design. 

 Right-of-Way is a powerful integrated software package for the analysis of electromagnetic 

interference between electric power lines and adjacent installations such as pipelines and 

communication lines. It is especially designed to simplify and to automate the modeling of 

complex right-of-way configurations. The Right-of-Way interface runs the TRALIN and SPLITS 

engineering modules and several other related components in the background. 

 SESEnviroPlus is a sophisticated program that evaluates the environmental impact (radio 

interference, audio-noise, corona losses, and electromagnetic fields) of AC, DC or mixed 

transmission line systems. 

 SESShield-3D is a powerful graphical program for the design and analysis of protective 

measures against lightning for substations and electrical networks. Its 3D graphical environment 

can be used to model accurately systems with complex geometries. 

 SESTLC is a simplified analysis tool useful to quickly estimate the inductive and conductive 

electromagnetic interference levels on metallic utility paths such as pipelines and railways 

located close to electric lines (and not necessary parallel to them), as well as the magnetic and 

electric fields of arbitrary configurations of parallel transmission and distribution lines. It can 

also compute line parameters. 

 CDEGS is a powerful set of integrated engineering software tools designed to accurately analyze 

problems involving grounding, electromagnetic fields, electromagnetic interference including 

AC/DC interference mitigation studies and various aspects of cathodic protection and anode bed 

analysis with a global perspective, starting literally from the ground up. It consists of eight 

engineering modules: RESAP, MALT, MALZ, SPLITS, TRALIN, HIFREQ, FCDIST and 

FFTSES. This is the primary interface used to enter data, run computations, and examine results 

for all software packages other than Right-of-Way, Autogrid Pro, AutoGroundDesign, SESTLC, 

SESShield-3D and SESEnviroPlus. This interface also provides access to the utilities listed 

below. 

TOOLS 
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 AutoTransient automates the process required to carry out a transient analysis with the HIFREQ 

and FFTSES modules 

 CETU simplifies the transfer of Right-of-Way and SPLITS output data to MALZ. A typical 

application is the calculation of conductive interference levels in an AC interference study.  

 FFT21Data extracts data directly from FFTSES’ output database files (File21) in a spreadsheet-

compatible format or in a format recognized by the SESPLOT utility. 

 GraRep is a program that displays and prints graphics or text files. For more information on 

GraRep see Chapter 6 of the Utilities Manual or invoke the Windows Help item from the menu 

bar. 

 GRServer is an advanced output processor which displays, plots, prints, and modifies 

configuration and computation results obtained during previous and current CDEGS sessions.  

 GRSplits plots the circuit models entered in SPLITS or FCDIST input files. This program 

greatly simplifies the task of manipulating, visualizing and checking the components of a 

SPLITS or FCDIST circuit. 

 GRSplits-3D is a powerful interactive 3D graphical environment that allows you to view and 

edit the circuit data contained in SPLITS input files and to simultaneously visualize the 

computation results.  

 ROWCAD is a graphical user interface for the visualization and specification of the geometrical 

data of Right-of-Way projects. Its 3D graphical environment can be used to visualize, specify 

and edit the path data of Right-of-Way, and to define the electrical properties of those paths. 

 SESAmpacity computes the ampacity, the temperature rise or the minimum size of a bare buried 

conductor during a fault. It also computes the temperature of bare overhead conductors for a 

given current or the current corresponding to a given temperature, accounting for environmental 

conditions.  

 SESBat is a utility that allows you to submit several CDEGS engineering program runs at once. 

The programs can be run with different JobIDs and from different Working Directories. 

 SESCad is a CAD program which allows you to create, modify, and view complex grounding 

networks and aboveground metallic structures, in these dimensions. It is a graphical utility for 

the development of conductor networks in MALT, MALZ and HIFREQ.  

 SESConductorDatabase gives access to the SES Conductor Database. It allows you to view the 

electrical properties of conductors in the database, and to add new conductors to the database or 

modify their properties. 

 SESEnviroPlot is a graphical display tool is an intuitive Windows application that dynamically 

displays arrays of computation data produced by the SESEnviro software module. 
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 SESGSE rapidly computes the ground resistances of simple grounding systems, such as ground 

rods, horizontal wires, plates, rings, etc, in uniform soils. SESGSE also estimates the required 

size of such grounding systems to achieve a given ground resistance. 

 SESPlot provides simple plots from data read from a text file. 

 SESScript is a simple programming language that automatically generates input files for 

parametric analyses. 

 SESShield provides optimum solutions for the protection of transmission lines and substations 

against direct lightning strikes and optimizes the location and configuration of shield wires and 

masts in order to prevent the exposure of energized conductors, busses and equipment. It can also 

perform risk assessment calculations associated with lightning strikes on various structures. 

 SESSystemViewer is a powerful 3D graphics rendition software that allows you to visualize the 

complete system including the entire network and surrounding soil structure. Furthermore, 

computation results are displayed right on the system components. 

 SoilModelManager is a software tool that automates the selection of soil model structures that 

apply during various seasons. 

 SoilTransfer utility allows you to transfer the soil model found in several SES files into several 

MALT, MALZ or HIFREQ input (F05) files. 

 TransposIT is a tool for the analysis of line transpositions on coupled electric power line 

circuits. To ensure that voltage unbalance is kept within predefined limits, it allows the user to 

determine the optimal number of power line transpositions and their required locations. 

 WMFPrint displays and prints WMF files (Windows Metafiles) generated by CDEGS or any 

other software. 

During this tutorial, for simplicity, we will be using the Windows CDEGS menu or toolbar icon to 

carry out most of the input and output tasks. We will refer to the other utility modules when 

appropriate. 

In the SES Software group folder, double-click the CDEGS icon to start the CDEGS program. You 

will get the CDEGS start-up window. 
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There are three main elements in the start-up window: selection of the Session Mode, definition of 

Working Directory and Current Job ID, and selection of the Engineering Programs. Enter the 

complete path of your working directory in the Working Directory field (or use the Browse button 

to find the directory). Any character string can be used for the Current Job ID. 

In the following session, we recommend the following Working Directory and Current Job ID as 

explained in Chapter 1: 

Working Directory:   C: (or D:) \CDEGS Howto\Tower 

Current Job ID:   TUT2A 

3.2 DEFINE PREFERENCE IN CDEGS SETTINGS 

You can edit preference in CDEGS default settings by clicking on Settings | Preference in the 

CDEGS Start Up Window. You can then customize the System of Units and System Frequency. In 

this case, we choose Metric and 60 Hz. Note that this will modify default CDEGS input files 

(XY_Default.F05). 

Specify Session 

Mode (Specify, 

Compute and 

Examine) 

Define Working 

Directory and 

Job ID 

Click here to 

start SESCAD 
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3.3 UNBALANCED CASE 

Click the SESCAD  button or select SESCAD under the Tools menu to start the SESCAD 

program. 

In the Select a file to open 

window, select Open the 

HIFREQ file HI_TUT2A.F05 < 

New Case>, this will open a new 

HIFREQ file HI_TUT2A.F05. 

System of Units and System 

Frequency are already specified 

(per Preference in CDEGS 

Settings). The following SESCAD 

screen will appear. As illustrated in 

Section 1.5, the abbreviation “HI” 

means that this is a HIFREQ input 

file and the Job ID is “TUT2A”. 

You are now ready to input data. In the following section, it is assumed that you are entering data as 

indicated in the instructions. Note that it is advisable to save your work regularly (select Save 

Document under the File menu). This file can be retrieved at any time by selecting Open 

Document… under the File menu. 

If you intend to enter the data in this example yourself, proceed directly to Section 0. If you do not 

wish to do so, you can import all the data by proceeding as follows. 

Set System of Units 

and System 

Frequency (Hz) 
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Importing DATA 

First be sure to close the HI_TUT2A.F05 which was just created. Select the Open 

Document…under the File menu. Browse to the file HI_02A.F05 in the working directory 

\CDEGS Howto\Tower, then click on the OK button to open the file. Click on Save Document 

As… and select the file HI_TUT2A.F05 in working directory to overwrite this file. The data 

described in the next section will be loaded and you will not have to enter it. 

 

3.3.1 Define Soil Model, Conductor Types and 
Energizations 

We will first define a Run ID and System of Units under the 

Define | Units and Other Settings… menu in the SESCAD 

window. In the Case Description block of this window, you can 

enter comment lines that are used to describe the case. They are 

echoed in the HIFREQ output (.F09 file). In this tutorial, 

“EXAMPLE2 - UNB” is entered under the Specify option of Run 

ID, and the Metric Systems of Units is chosen. Note that a Run ID 

is different from the Job ID. The run-id is a string that is used to 

identify plots, such as those that will be made in Section 4.3, 

whereas the JobID is simply part of the file names. 

Under the Define menu in the SESCAD window, select Soil Model 

to access the soil structure dialog. HIFREQ supports horizontally layered soils, with any number of 

layers (Uniform, Horizontal – 2 Layer, Horizontal – 3 Layer and Horizontal – Multilayer): It 

also supports an Infinite Medium soil model. Select a Uniform soil. The data entry fields in the Soil 

Characteristics block allow you to define the 

properties of the air and earth. In this example, the 

default properties for both the air and the earth (a soil 

with resistivity of 100 -m, relative permeability and 

relative permittivity of 1) are used. Click OK to return 

to the SESCAD main screen. 

Four types of conductors are encountered in this study: 

Steel conductors for the tower, a 1565 kcmil 36/7 

ACSR for the phase conductors, a steel tube for the 

fence, and copper conductors for the tower’s 

grounding grid. These conductor types are specified by 

clicking on the Define | Conductor Types menu and 

entering the data, which includes resistivity, 

permeability, internal radius and load of the conductor. 
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Conductor type No. 1 is defined as steel and Conductor Type No. 2 is defined as aluminum (1565 

kcmil 36/7 ACSR). A steel tube with an internal radius of 1 cm is defined as Conductor Type No. 3. 

Conductor Type No. 0 is a default conductor, which is pure copper, unless it has been redefined. 

Note that it is recommended to assign names to different conductor types. Click OK to return to the 

SESCAD main screen. 

The conductors in this example are not coated. 

The energization of the transmission line is 

carried out by means of LEAD and GPR 

(Ground Potential Rise) energizations: the 

first injects a current in the network and 

the second maintains the conductors at a 

desired potential. The current and potential 

are specified by clicking on the Define | 

Energization Types menu in the SESCAD 

screen. The magnitude and phase of the 

currents and GPRs are entered in the 

following screen. 

The energizations are shown above. For example, Bus No. 1 is a LEAD energization with current 

4250e
-j123

 A, Bus No. 5 is a GPR energization with potential 303000e
j0

 Volts, and so on. Click OK 

to return to the SESCAD main screen. 

3.3.2 Define Conductor Network 

With the conductor types, coating types and energization types specified, the conductor network can 

now be defined and energized. SESCAD is the perfect tool to build the system under study. 

3.3.2.1 Define Transmission Line Tower at Y = 0 m 

Let us start by defining a transmission line tower at Y = 0 m. The following lists the required steps: 
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1. Import Tower: (a) Under the File menu in SESCAD, select Database Manager | SES | 

Towers. (b) Select Transmission 1 and leave Desired Scaling Factors as “1”. This is 

because the size of the tower in the database is the same as that described in Chapter 2. (c) 

Click the Paste In Document button and choose Do not import in the File Import Options 

screen. This will import the tower into SESCAD, as shown in the screen below. 

 

2. Set Conductor Characteristics of Tower: The conductor characteristics of the tower has 

also been defined when the tower is imported. The following provides steps if you wish to re-

define them. (a) Click the Zoom To All Objects button  (or select Zoom To All Objects 

(CTRL+F) under the Display menu). (b) Change the view to X-Z and Orthogonal 

Projection View. (c) Select the entire tower. Right click and select Group to group all 

conductors into a single object. (d) Right click on the tower and select Characteristics… In 

the Characteristics screen, select Conductor Type as Steel (make sure the check box is 

selected) and enter radius of 1.5 cm. This will define all conductors of the tower as steel with 

a radius of 1.5 cm. 
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3. Set Conductor Characteristics of Tower Grounding System: Similarly, the conductor 

characteristics of the tower grounding has also been defined when the tower is imported. The 

following provides steps if you wish to re-define them. (a) With the tower selected, press the 

F9 function key (or select Set As Active Object under the Advanced menu). This will 

enable you to edit conductors inside a grouped object without ungrouping the object. (b) 

Change the view to X-Z Plan View. Select only conductors below earth surface (by clicking 

and dragging the mouse to form a selection area). (c) Right click on the selected object and 

select Characteristics… in the menu. In the Characteristics screen, select Conductor Type 

as Default Conductor (copper unless redefined) and specify a radius of 7 mm. (d) Press the 

Shift+F9 function key (or select Set Parent As Active Object under the Advanced menu). 

This will exit the grouped object selection. 

 

Click here to 

change to XY, 

XZ, YZ, 3D or 

Plan Views 

Click here to Explore, 

Zoom, Zoom to All 

Objects, Zoom to Selected 

Objects, Zoom In and Out 

objects 
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3.3.2.2 Define Two Simplified Towers at Y = + 400 m and Y = - 400 m 

Next, we will create the other two towers, which are a simplified form of the tower just imported. 

The two towers are located at Y = + 400 m and Y = - 400 m, along Y-axis. The following provides 

the steps needed (be sure to choose X-Y View): 

1. Create 16 m × 16 m Tower Base: (a) Under the Edit menu, select Create Object | Simple 

Grid. Specify width=16 m, height=16 m, and burial depth = 0.5 m. Numbers of horizontal 

and vertical conductors are set to 3. Click the Apply and then the Close buttons. This will 

create a loop with a cross. (b) Right click on the loop and select Characteristics... in the 

menu. In the Characteristics… screen, define a Default Conductor with a radius of 7 mm 

and subdivided it into 3. This will create the base of the simplified tower model at Y = 0 m. 

2. Move Tower Base to Y = + 400 m: (a) With the loop still selected, under the Tools menu, 

select Shift Objects… (b) Enter 400 m under the Quick Distance and click the Move Up 

arrow to move the loop in + Y direction. 

3. Create Four Ground Rods: (a) With the loop still selected, under the Tools menu, select 

Create Rods | Create Rods at Nodes. Select only Create rods at origin and end of 

conductors, enter 9.5 m as Rods Heights. Click OK to apply. (b) With all rods still selected, 

press the F9 function key (or select Advanced | Set As Active Object menu) to get inside 

the group. Remove the four rods at mid-point on each side of the tower. Press the Shift+F9 

function key to exit the grouped object. 

 

4. Create Copy of Tower at Y = - 400 m: (a) Select both the tower base and the four ground 

rods. Under the Edit menu, select Group to group them. (b) Under the Tools menu, enter 

800 m under the Quick Distance and select Apply to Duplicate. (c) Click the Move down 

arrow to move the object in –Y direction. 

Click here to 

move 400 m up 
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3.3.2.3 Define Phase Conductors, Shield Wires and Connect Shield Wires To 
Towers 

Next, we will define transmission line phase conductors, shield wires and connections between 

shield wires and phase conductors (see Figure 2.1) by using the data in the following Table 3.1. 

Conductor Starts 

(XS, YS, ZS)  

Ends 

(XP, YP, ZP) 

Radius 

(m) 

No. 

Subdivision 

Conductor 

Type 

Shield #1 (-7.773, -400, -35), (-7.773, 400, -35), 0.00635 40 1 

Shield #2 (7.773, -400, -35) (7.773, 400, -35) 0.00635 40 1 

Phase B (-10, -400, -27) (-10, 400, -27) 0.0191 40 2 

Phase C (0, -400, -27) (0, 400, -27) 0.0191 40 2 

Phase A (10, -400, -27) (10, 400, -27) 0.0191 40 2 

Connection Shield#1 

at Y = +400 m 

(-7.773, 400, -35) (-7.773, 400, 0.5) 0.015 1 1 

Connection Shield#2 

at Y = +400 m 

( 7.773, 400, -35) ( 7.773, 400, 0.5) 0.015 1 1 

Connection Shield#1 

at Y = -400 m 

(-7.773, -400, -35) (-7.773, -400, 0.5) 0.015 1 1 

Connection Shield#1 

at Y = -400 m 

( 7.773, -400, -35) ( 7.773, -400, 0.5) 0.015 1 1 

Table 3.1 Data for Phase Conductors, Shield Wires and Connections 

Perform the following steps and be sure to choose X-Y View: 

1. Create Shield Wire #1 and #2: Under the Edit menu, select Create Object | Single 

Conductor. Specify (X, Y, Z) coordinates of Starts and Ends for Shield #1 in Table 3.1. 

Click Apply and then Close. Right click on the conductor and select Characteristics… in 

the menu. In the Characteristics screen, select Steel conductor, set radius=6.35 mm and 

Subdivision # = 40. 

Click here to move 

800 m down 

Check here to 

duplicate 
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With the Shield Wire #1 still selected, under the Tools menu, select Shift Objects. Enter 

15.546 m under the Quick Distance; select Apply to Duplicate. Click the Move to the right 

arrow to move in + X direction. This will create Shield Wire #2. 

2. Create Phase Conductors B, C and A: The three phase conductors in Table 3.1 can be 

created similarly. First create Phase B using the data in Table 3.1. In the Characteristics 

screen, make sure to select Aluminum as Conductor Type and set radius=19.1 mm and 

Subdivision # = 40. 

Under the Tools menu, select Shift Objects to create Phases C and A. Enter 10 m under the 

Quick Distance and Number of Duplicates = 2. 

3. Connect Shield #1 and #2 to Tower at Y = + 400 m: Under the Edit menu, select Create 

Object | Single Conductor. Specify (X, Y, Z) coordinates of Starts and Ends for 

Connection Shield #1 in Table 3.1. Click Apply and then Close. Right click on the conductor 

and select Characteristics… In the Characteristics screen, select Steel conductor, 

radius=15 mm and Subdivision # = 1. 

With the Connection Shield Wire #1 still selected, under the Tools menu, select Shift 

Objects to create Connection Shield Wire #2. Enter 15.546 m under the Quick Distance and 

set Number of Duplicates to 1. 

4. Connect Shield #1 and #2 to Tower at Y = - 400 m: Repeat the previous step, but set Y = - 

400 m. Note that by using Tools | Shift Objects, you can also create these connections by 

making a duplicate of the two conductors in the previous step, along Y-axis, and with a 

Quick Distance = 800 m. 

Note that the tower at Y = 0 m is automatically connected to the two shield wires. 

 

Click here to move 

15.546 m right 
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3.3.2.4 Define Energized Phase Conductors 

Next, we will define six short conductors which are attached to the transmission line phase 

conductors to energize the line. These six conductors are defined in the following Table 3.2. 

 

Identification Energization 

Type 

Starts 

(XS, YS, ZS)  

Ends 

(XP, YP, ZP) 

Radius 

(m) 

Energization 

(Bus Number) 

Lead-PhaseB LEAD (-10, -400.5, -27) (-10, -400, -27) 0.0191 1 

Lead-PhaseC LEAD (0, -400.5, -27) (0, -400, -27) 0.0191 2 

Lead-PhaseA LEAD (10, -400.5, -27) (10, -400, -27) 0.0191 3 

GPR-PhaseB GPR-Potential (-10, 400.5, -27) (-10, 400, -27) 0.0191 4 

GPR-PhaseC GPR-Potential (0, 400.5, -27) (0, 400, -27) 0.0191 5 

GPR-PhaseA GPR-Potential (10, 400.5, -27) (10, 400, -27) 0.0191 6 

Table 3.2 Data for Energized Conductors 

The LEAD (current) type energization of Phase C is carried out by a 0.5 m long conductor at Y = -

400.0 m. The conductor is connected to Bus Number 2, which is defined to be a lead type 

energization with current 4300e
-j0 

A (click on Define | Energization Types…). A current of 4300 A 

is flowing into the phase conductor from Ys = -400.5 m towards Yp = -400 m. Note that a completely 

different situation occurs if the Y coordinates of the origin and end of this conductor are 

interchanged. In this case, the program would force the current to be zero at Y = -400.5 m since this 

point is not connected to any other conductors and the result would be that the entire 4300 A would 

have to leak between Y = -400 m and Y = -400.5 m, generating huge potentials and electric fields. 

Using a similar 0.5 m long conductor at Y = 400.0 m, the other end of the line, the 303 kV potential 

on the phase conductor is clamped by applying a GPR type energization. The Bus Number refers to 

an energization of type 5. The GPR energization will, at the same time, absorb all the current 

flowing in the Phase wire C at the conductor end corresponding to Y = 400 m since currents cannot 

be allowed to leak into the air from the end of a conductor. The other phases are energized in a 

similar way. Note that a GPR energization must be applied on a pseudo node (nodes in contact with 

medium, such as air or soil). Therefore, the start of conductors with GPR energizations is Ys = 400.5. 

Perform the following steps, be sure to choose X-Z View, Orthogonal Projection View: 

1. Create Lead-PhaseB: Under the Edit menu, select Create Object | Single Conductor. 

Specify (X, Y, Z) coordinates of Starts and Ends for Lead-PhaseB in Table 3.2. Click the 

Apply and then the Close button. Right click on the conductor and select Characteristics… 

In the Characteristics screen, select an aluminum conductor (Type 2) and select Lead-

PhaseB as the energization (Type 1). Set the radius=19.1 mm and Subdivision # = 1. 

2. Create Lead-PhaseC and Lead-PhaseA: With the Lead-PhaseB still selected, under the 

Tools menu, select Shift Objects. Enter 10 m under the Quick Distance. Select Apply to 

Duplicate and Number of Duplicates = 2. Click the Move to the right arrow to move in 

+ X direction. This will create Lead-PhaseC and Lead-PhaseA. 
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Right-click on the Lead-PhaseC conductor and select Characteristics. Select Lead-PhaseC 

from the Energization drop-down menu. Repeat similarly for Lead-PhaseA conductor, but 

select Lead-PhaseA from the Energization drop-down menu. 

3. Create GPR-PhaseB, GPR-PhaseC and GPR-PhaseA: These three conductors are created 

similarly by repeating the previous two steps. The energization types are Types 4, 5 and 6. 

Voltage energizations can also be used to energize the transmission line. The VOLTAGE 

energization allows for more realistic modeling at the expense of a little bit more work. In this case, 

we need three VOLTAGE energizations, one for each phase. Furthermore, an impedance, typically a 

resistor, must be attached to each phase to limit the current flow. A resistance of 70.5   (=       

            , which is much larger than the impedance of the wires) will give a current of 4300 A, 

as before. 

 

This completes the model of the transmission line. 

3.3.2.5 Define Fence 

Next, we will model the fence. We will first build a 3 m long fence section, then complete the entire 

fence by duplicating and rotating the 3 m long fence section. Table 3.3 lists five conductors to 

construct the 3 m long fence section which is at the corner of X = -16 m, Y = -6 m. 
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Fence Elements Starts 

(XS, YS, ZS)  

Ends 

(XP, YP, ZP) 

Radius 

(m) 

Conductor 

Type 

Subdivisions 

Fence post part 1 (-16, 6, -1.5) (-16, 6, 0) 0.02 3 1 

Fence post part 2 (-16, 6, 0) (-16, 6, 1) 0.02 3 2 

Horizontal bar (-16, 6, -1.5) (-19, 6, -1.5) 0.02 3 2 

Cross wire#1 (-16, 6, 0) (-19, 6, -1.5) 0.003 1 1 

Cross wire#2 (-16, 6, -1.5) (-19, 6, 0) 0.003 1 1 

Table 3.3 Data for Fence Section 

The following provides the steps, be sure to choose X-Y, Orthogonal Projection View: 

1. Create Fence Section in Table 3.3: Similar to what we did before, we can create the five 

conductors in Table 3.3 by using Create Object | Single Conductor under the Edit menu. 

Two types of conductors are used: Type 1 (solid steel) and Type 3 (fence post). Fence post 

part 2 and Horizontal bar conductors are subdivided into two segments for better leakage 

current computation. 

 

2. Duplicate Fence Section along Y =+ 6 m: (a) Select the fence section created in the 

previous step. Right-click on it and select Group to group them. (b) Under the Tools menu, 

select Shift Objects. Enter 3 m under the Quick Distance. Select Apply to Duplicate. Set 

Number of Duplicates = 10. Click the Move to the left arrow to move in - X direction. 
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3. Duplicate Fence Section along X =-46 m: Select the last fence section created in the 

previous step, with its fence post at X = -46 m, Y = +6 m. Under the Tools menu, select 

Rotate Objects. Enter X = -46, Y = 6 under Set Origin and click the Apply button. Make 

sure that Apply to Duplicates is off and enter a 90 degree angle. Click the Rotate counter 

clockwise button to rotate this fence section by 90 degree. Under the Tools menu, select 

Shift Objects. Enter 3 m under Quick Distance. Select Apply to Duplicate. Set Number of 

Duplicates = 4. 

 

4. Duplicate Fence Section along Y = -6 m: (a) Select the last fence section created in the 

previous step, with its fence post at X = -46 m, Y = - 6 m. Under the Tools menu, select 

Rotate Objects. (b) Enter X = -46, Y = - 6 under Set Origin and click the Apply button. (c) 

Make sure that Apply to Duplicates is off and enter a 90 degree angle. Click the Rotate 

Click here to rotate 

counter-clockwise 90 

degree 
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counter clockwise button to rotate this fence section by 90 degree. (d) Under the Tools 

menu, select Shift Objects. Enter 3 m under Quick Distance. Select Apply to Duplicate. 

Set Number of Duplicates = 10. 

 

5. Duplicate Fence Section along X = -16 m: (a) Select the last fence section created in the 

previous step, with its fence post at X = -16 m, Y = - 6 m. Under the Tools menu, select 

Rotate Objects. (b) Enter X = -16, Y = - 6 under Set Origin and click the Apply button. (c) 

Make sure that Apply to Duplicates is off and enter a 90 degree angle. Click the Rotate 

counter clockwise button to rotate this fence section by 90 degree. (d) Under the Tools 

menu, select Shift Objects. Enter 3 m under Quick Distance. Select Apply to Duplicate. 

Set Number of Duplicates = 3. 

 

This completes the modeling of the fence. 
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3.3.2.6 Define Observation Points for Computation 

In this example, the electric and magnetic fields and the scalar potential are computed for a single 

frequency (60 Hz). Note that these quantities are selected by default in HIFREQ. There are 101  81 

observation points, all located at 5 cm above the earth’s surface (i.e. at Z = -0.05m, negative Z being 

above the ground in HIFREQ). The points start at X = -60 m, Y = 40 m with increments of 1m in the 

X direction and -1m in the Y direction. 

To specify those points, make sure to be in the X-Y View. Under the Edit menu, select Create 

Object | Detailed Surface. Enter the data as shown in the following screen. Select Specify profiles 

by Step option. Click Apply and then Close. This instructs the program to a total of 81 parallel 

profiles, each of which consists of 101 points. 

 

When the height of the observation point is precisely zero (i.e. the observation point lies at the air-

soil interface), HIFREQ assumes that the point is in the ground for the purpose of calculating the 

electric and magnetic fields. If the fields in the air but close to the air-soil interface are desired, an 

observation profile must be specified at a small height above the ground. This is the reason behind 

the choice of a height of 0.05 m for the observation points. 

At this point, you have completed the preparation of the data. Under the File menu, select Save 

Document and then click Close Document to close this file in SESCAD. The *.F05 is an ASCII 

files you can edit and view at any time. 

The file HI_TUT2A.F05 is ready to be submitted to the HIFREQ engineering module in the next 

chapter. 

3.4 THE FAULT CASE 

Only a few changes to the previous input file are needed to produce a model for a fault at the tower. 

The input file corresponding to the fault is available in your CDEGS directory under the name 

HI_02B.F05. 

To prepare the HIFREQ input file for the fault case in SESCAD, we can simply reload the input file 

just prepared for the Unbalanced Currents Case HI_TUT2A.F05 in SESCAD. Save it as 

HI_TUT2B.F05 and modify it slightly (see next). 
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If you do not wish to go through these steps, you can import all the data from the file HI_02B.F05 

that has been prepared for you. 

Importing DATA 

First be sure to close the HI_TUT2B.F05 which was just created. Select the Open 

Document…under the File menu. Browse to the file HI_02B.F05 in the working directory 

\CDEGS Howto\Tower, then click on the OK button to open the file. Click on Save Document 

As… and select the file HI_TUT2B.F05 in working directory to overwrite this file. The data 

described in the next section will be loaded and you will not have to enter it. 

It is recommended to use a different Run-Identification (EXAMPLE2 - FAULT) for this case in 

order to avoid confusion. (Under the Define menu in SESCAD, select Units and Other Settings… 

to specify “EXAMPLE2 – FAULT” as Run ID). 

The energization of the network must be changed completely. The new ENERGIZATION data 

reads: 

Bus 
Identification 

Type Magnitude 

(Amps) 
Angle (Deg) 

1 Lead-PhaseB Lead 430 -120 

2 Lead-PhaseC Lead 430 0 

3 15 kA-PhaseA Lead 15000 0 

4 GPR-PhaseB GPR-Pot 303000 -120 

5 GPR-PhaseC GPR-Pot 303000 0 

6 Zero-PhaseA Lead 0 0 

Table 3.4 Energizations for the Fault Case 

As shown in the screen below, this is done under the Define menu, select Energization Types. 

The situation is now as follows. Phases B 

and C are assumed to be unaffected by the 

fault. They carry a current of 430 Amps and 

are at 303 kV. To simulate the fault, a 

current of 15000 Amps is injected at the Y 

= -400 m end of Phase A while a current of 

0 Amps is injected at the other end. This is 

as shown in Figure 3.1. To simulate a fault 

where current comes in from both sides, one 

simply has to change the third and sixth 

energizations accordingly. 
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Figure 3.1 Fault Currents 

Furthermore, a new conductor must be introduced to short Phase A and a shield wire at Y = 0. We 

can create the fault conductor by selecting Create Object | Single Conductor under the Edit menu 

according to the following table. 

Xs 

(Origin) 

Ys 

(Origin) 

Zs 

(Origin) 

Xp 

(End) 

Yp 

(End) 

Zp 

(End) 

Radius Nseg Cond Coat Bus 

12 0 -31.0 10.0 0 -27 .0191 1 0 0 0 

Table 3.5 Fault Conductor 

All other conductors are as before. 

The earth potentials are of interest here, so the location of the observation points has to be shifted to 

the surface of the earth (Z = 0). This is done by first selecting the profiles surface (a grouped object) 

and by selecting Shift Objects under the Tools menu. Enter 0.05 m under the Quick Distance and 

click the Move down arrow to shift it down by 0.05 m in the Z direction. 

We have now completed the modification of the data. Under the File menu, select Save Document. 

The *.F05 is an ASCII files you can edit and view at any time. 

Now the file HI_TUT2B.F05 is ready to be submitted to the HIFREQ engineering module in the 

next chapter. 

If you are a licensee of the CDEGS software you will now be able to proceed to Chapter 4. Users of 

the demo software are not able to process the input file, but are able to peruse all output files that are 

already available. Therefore read Chapter 4 for reference only. Any attempt to start the engineering 

modules will result in a message stating that the Engineering module is not active. 
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CCCHHHAAAPPPTTTEEERRR   444 

HOW TO SUBMIT THE HIFREQ RUNS 

There are two ways to submit HIFREQ runs 

4.1 SUBMIT ENGINEERING PROGRAM USING SESCAD 

You can submit the engineering run directly from SESCAD, by selecting the Run/Reports | Save & 

Run menu item. This will start the SESBatch program and automatically run the engineering 

module.  Note that for illustration purposes, the generic grounding grid shown in the following 

screen shot has been used instead of the specific case discussed in this How To manual. 

 

Once the run is complete, a window will pop up to inform you that a log file has been generated. 

Click the OK button to close the message window. SESBatch allows you to conveniently access 

some of the important files that it generates. For example, from the Tools | View Run Log File… 

menu item you can view the log file generated during the computations. From the Tools | View 

Output File… menu item you can view the output file, which may contain ERROR or WARNING 

messages requiring your attention. Finally, you can launch Output Toolbox directly from the Tools | 

View Results with Output Toolbox… menu item. 
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4.2 SUBMIT ENGINEERING PROGRAM USING CDEGS 

In this section, the two input files prepared in the last section will be submitted to HIFREQ. We can 

start with JobID TUT2A. Select ‘Compute’ from the Session Mode drop-down list. 

 

The HIFREQ program will start and carry out all requested computations. Upon completion, the 

program will produce three important files: an OUTPUT file (HI_TUT2A.F09), a REPORT file 

(HI_TUT2A.F17) and a DATABASE file (HI_TUT2A.F21). 

The OUTPUT and REPORT files are ASCII files, while the DATABASE file is a binary file. Any 

ERROR or WARNING messages generated during the HIFREQ run will appear in the OUTPUT 

file. You can view the output file by clicking on the File Viewer ( ) button in the Output section 

of the toolbar. You can also use the GraRep utility (See Section 3.1) to view and edit any ASCII 

output files. 

Depending on your settings, the program may automatically start the output session the moment the 

engineering program terminates. This is controlled by the option View the output session after 

engineering computations in the “System Settings” window (accessible from the Settings | System 

menu item). 

Change Session 

Mode to 

Compute 
Click here to 

launch HIFREQ 
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If the Output Session started, click  in the toolbar to go back to the CDEGS startup screen. 

The second input file HI_TUT2B.F05 can be submitted similarly. 

Optionally, you can submit both runs by using SESBatch under Tools menu. Click on Edit | Add 

Runs to load the input files). Click the Launch button to run. 

 

 

Click here to 

load input 

F05 files 
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HOW TO EXTRACT RESULTS FROM THE 

HIFREQ OUTPUT FILES 

The OUTPUT file contains all the information from your HIFREQ run. It contains the current 

distribution and the ground potential rise (GPR) for each conductor segment, as well as the requested 

scalar potentials and electromagnetic fields computed at the specified observation points. With the 

SES Text viewer or any other text editor, searching for the string "Leaking" will get you to the 

location of current distributions of segments quickly, searching for the string "Scalar" will get you to 

the location of the GPR or scalar potential quickly, and so on. The REPORT file only contains the 

conductor information and the current distribution for each conductor segment. It is written in a 

format such that this file can be readily appended to your original input file for a second round of 

computations where the current computation will be bypassed. Note, however, that this feature 

should not be used when above ground conductors are involved since the currents are not stored to a 

high enough precision for such use. 

The DATABASE file is normally used by the Windows Output Session and the SES Interactive 

Report & Plot Software processors (such as GraRep) to display the computation results. The 

computation results can be classified into two categories: CONFIGURATION plots and 

COMPUTATION plots. The CONFIGURATION plots allow you to view the conductor network, to 

label the conductor segments with their GPR, longitudinal and leakage currents, and so on. The 

COMPUTATION plots allow you to examine the scalar potential and the electromagnetic fields 

computed at selected observation points. In the following, we will give several examples to show 

how to use the Windows Toolbox interface (Section 5.1) to produce the corresponding graphs. 

5.1 WINDOWS MODE OUTPUT PROCESSOR 

We will first extract the results from the unbalanced currents case and follow with those 

corresponding to the fault case. 

5.1.1 Unbalanced Currents: 

In the CDEGS main screen, enter TUT2A under the Current JobID. Select ‘Examine’ from the 

Session Mode drop-down list. If the CDEGS-Examine-HIFREQ screen is not already loaded, click 

on the HIFREQ button to load this screen. You are now ready to make Computations and 

Configuration plots. 

Figure 5.1 and Figure 5.2 show the electric and magnetic fields around the base of the tower. Click 

the Computations option button (at the top of the screen). The HIFREQ (Computations) screen 

should appear. 
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Select Electric Fields under Report Computation Results 

for to plot electric field, select the 3D Perspective in the 

View block and click Plot/Draw. Figure 5.1 should appear 

on your screen, along with an icon of the plot. By clicking on 

this icon later in the session, this figure can be made the 

active plot again. 

 

 

 

 

 

 

 

Figure 5.1 Electric Field Around Tower and Fence 

To generate Figure 5.2, simply select Magnetic Fields under Report Computation Results for and 

click Plot/Draw. This produces Figure 5.2 on your screen along with an icon. Since some of the 

observation points are close to the tower legs, four very large peaks can be seen in the figure. 
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Figure 5.2 Magnetic Field Around Fence and Tower 

To clip those peaks to (say) 30 Amps/m, click on Setup from the Settings menu. Under Axes-

Limits, select User-defined and enter the values according to the following screen. Then, click 

Draw. 

 

This produces Figure 5.3 on your screen. Now click OK to go back to the HIFREQ 

(Computations) screen. Note that the user-defined axes in the setup screen affects the general 

appearance of the plots. 
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Figure 5.3 Close-Up on Magnetic Field Around Fence and Tower 

To produce the current distribution shown in Figure 5.4, you first have to click on the Configuration 

option button to select conductor configuration plots. The Longitudinal Currents Flowing in 

Origin of Conductor is selected from the Data Type list. Because only the currents in the base of 

the tower are desired, we will “zoom-in” on this region. This feature is invoked by selecting the 

Zoom Polygon option under Conductor Selection. 

The four Data Entry fields P1 to P4 define a rectangular surface in the X-Y plane, and the Depth 

defines the top and bottom plane to form a rectangular box. All the conductors located in the region -

10 <= X <= 10,  -10 <= Y <= 10, -2 <= Z <= 15 are plotted and labeled with value of the current 

flowing into them. The zoom region was selected with reference to Figure 2.1, which shows that the 

base of the tower is located entirely in this region. Click Plot/Draw. 
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Figure 5.4 Induced Currents in the Base of the Tower 

Enter zoom 

coordinates 

here 

Set Ztop = -2 

and Zbot=15 
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Once you are done examining the results, click  in the toolbar to go back to the CDEGS startup 

screen. 

5.1.2 Fault Case: 

To examine the results for the fault case, the JobID must first be changed to “TUT2B”. This is done 

by entering the string “TUT2B” in the Current Job ID box. Next, start the Examine Session by 

clicking the HIFREQ button in the CDEGS screen. 

Figure 5.5 and Figure 5.6 show the ground potential around the tower and the current distribution on 

the fence respectively. To produce these plots, click on the Computations option button. Scalar 

Potentials is selected, by default, under “Report Computation Results for”. Select Scalar 

Potentials under Determine, and click Plot/Draw. Figure 5.5 should appear on your screen, along 

with an icon of the plot. 

 

Figure 5.5 Ground Potential around Tower and Fence Under Fault Conditions 

As before, the current distribution on the fence is produced by selecting the Configuration radio 

button and selecting Longitudinal Current Flowing in Origin of Conductor from the Data Type 

list. To zoom in the region where the fence is located, the following values are entered into the four 

Data Entry fields P1 to P4 that delimitate a region in the X-Y plane. All conductors that lie in this 

region are plotted (for all values of their Z coordinates). This region was chosen with reference to 

Figure 2.1, which shows that the fence is entirely contained in it. The conductors are labeled with the 

current flowing into them. Click Plot/Draw. The result is shown in Figure 5.6. 
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Figure 5.6 Currents Induced on the Fence 

The currents are perhaps a little crowded on that figure. One way to improve on this is to magnify 

the Z-direction with Z-exp = 1 replaced by Z-exp = 3 in the View Block. Click Plot/Draw. Figure 

5.7 should appear on your screen. This figure has its Z scale expanded 3 times. 

To improve the readability further, it is possible to cut the figure into pieces. For example, replacing 

XDiv = 1 with XDiv = 2 in the Sector block will split the figure into two, along the X axis. Click the 

Setup button and in the Setup screen, select the User-Defined Character Height = 0.2 

Centimeters. The resulting graphs are shown in Figure 5.8. Note that the previous Z-exp = 3 under 

View was still in effect. 

Enter zoom 

coordinates 

here 

Select 

Longitudinal 

Current… 

Set Z-exp 
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Figure 5.7 Currents Induced on the Fence (Magnified) 

 

Figure 5.8 Induced Currents on the Fence (Magnified and in Two Sections) 
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CONCLUSIONS 

This concludes our concise step-by-step instructions on how to prepare, submit and examine results 

for the HIFREQ, Electromagnetic Field Analysis Engineering module. 

As already mentioned, you could accomplish all these operations using the command input and 

output processors as well. The results are essentially the same. 

Only a few of the many features of the software have been used in this tutorial. You should try the 

many other options available to familiarize yourself with the CDEGS software package. Your SES 

Software DVD also contains a wealth of information stored under the PDF directory. There you will 

find the Getting Started with SES Software Packages manual (\PDF\getstart.pdf) which contains 

useful information on the CDEGS environment. You will also find other How To…Engineering 

Guides, Annual Users’ Group Meeting Proceedings and much more. All Help documents are also 

available online. 
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WINDOWS TOOLBOX INPUT MODE 
Any of the interfaces listed below or a text editor can be used to prepare the input data. The 

Windows input modes convert the results of an input session to a Command Mode compatible 

ASCII input file which can be edited at any time. 

 The Windows Input mode. 

 The Command Mode. 

 Plain Text Editor Mode. 

The following section describes the Windows compatible Input session, which is used to generate 

the SICL (SES Input Command Language) mode compatible input files, (*.F05 file extensions) 

described in Printout B.1 in Appendix B both of which can be reloaded during subsequent sessions. 

The most important features in preparing the data are explained in Section A.1, which also describes 

some tricks on how to avoid common input problems. 

During this tutorial, for simplicity, we will be using the Windows CDEGS menu or toolbar icon to 

carry out most of the input and output tasks. We will refer to the other utility modules when 

appropriate. 

In the SES Software group folder, double-click the CDEGS icon to start the CDEGS program. The 

following screen will appear. 

 

You will be prompted for a Working Directory and a Current Job ID. Enter the complete path of 

your working directory in the Working Directory box (or use the Browse button to find the 
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directory). Any character string can be used for the Current Job ID – TUT2A is recommended for 

this part of this tutorial. 

Click the HIFREQ button located within the toolbar. The HIFREQ screen will appear as shown 

below (but without the text) and you are now able to input data. 

In the following section, it is assumed that the reader is entering the data as indicated in the 

instructions. Note that it is advisable to save your work regularly with the use of the File | Save 

menu item. The entered data will be saved in an editable (text) files called HI_TUT2A.F05. Each file 

can be retrieved at any time with the use of the File | Import / Load menu item. The same method 

can be used if a Specify session has to be interrupted (click Cancel then close all active windows to 

exit after saving your data). 

If you intend to enter the data manually, proceed directly to Section A.1. If you do not wish to do so, 

you can import all the data by proceeding as follows. 

Importing DATA 

Click on the File | Import/Load menu item Change the File Name in the dialog box to 

HI_02A.F05 then click on the Load button in the dialog box. The data described in the next section 

will be loaded and you will not have to enter it. 

 

A.1 DATA ENTRY 

A.1.1 Unbalanced Case 

As shown in Figure B.1, the HIFREQ commands are 

grouped into modules, reflecting the hierarchical nature 

of the SES Input Command Language. Each module of 

Figure B.1 (with the exception of the OPTION 

module) is associated to a button in the HIFREQ 

screen. The OPTION module is actually part of the 

HIFREQ main screen. 

The Help Key (F1) can be used to obtain relevant 

context-sensitive information when any CDEGS Input 

or Output text field is selected. 

The data entry field in the Module Description tab 

allows you to enter comments that will be used to 

describe the case to be analyzed in the HIFREQ 

module. They are shown in the HIFREQ output. 

If you place your mouse cursor on any comment line 

and click on it (i.e., focus on the comment line) then hit 

the F1 (Help Key) display help text relevant to the 
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Comments text input area will be displayed. 

A run-id EXAMPLE2 - UNB is entered in the Run-Identification data entry field and the Metric 

System of Units is chosen. Focusing on the Run-ID field and then hitting the F1 key will bring a 

help text related to that field. 

The soil structure is defined by clicking on Soil Type 

button. The following screen will appear. HIFREQ supports 

horizontally layered soils, with any number of layers 

(Uniform, Horizontal – 2 Layer, Horizontal – 3 Layer 

and Horizontal – Multilayer): It also supports an Infinite 

Medium soil model. Select a Uniform soil. The data entry 

fields in the Soil Characteristics block allow you to define 

the properties of the air and earth. In this example, the 

default properties for both the air and the earth (a soil with 

resistivity of 100 -m, relative permeability and relative 

permittivity of 1) are used. You can therefore simply click 

OK to return to the HIFREQ main screen. 

In the SYSTEM module, which is invoked by clicking on 

the System button, the Characteristics of conductors (such 

as conductor types, coating types) as well as the specified 

Conductor Currents and Energization modes 

are defined in the Define block, then the 

conductor network is entered and energized under 

the Main-Ground Conductors block. The 

Subdivision block allows you to specify the total 

number of conductor segments desired. 

Four types of conductors are encountered in this 

study: Steel conductors for the tower, a 1565 

kcmil 36/7 ACSR for the phase conductors, a 

steel tube for the fence, and copper conductors 

for the tower’s grounding grid. These conductor 

types are specified by clicking on the Conductor 

Types button and entering the data, which 

includes resistivity, permeability, internal radius 

and load of the conductor. 

Conductor type No. 1 is defined as steel and 

Conductor Type No. 2 is defined as aluminum 

(1565 kcmil 36/7 ACSR). A steel tube with an 

internal radius of 1 cm is defined as Conductor 

Type No. 3. Conductor Type No. 0 is a default conductor, which is pure copper, unless it has been 

redefined. 
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The conductors in this example are not coated. 

The energization of the transmission line is carried out by means of LEAD and GPR energizations: 

the first injects a current in the network and the second maintains the conductors at a desired 

potential. The current and potential are specified by clicking on the Energization button in the 

HIFREQ (System) screen. The magnitude and phase of the currents and GPRs are entered in the 

following screen. 

  

The energizations are shown on this screen. For example, Bus No. 3 is a LEAD energization with 

current 4000e
-j119

 A, Bus No. 5 is a GPR energization with potential 303000e
j0

 Volts, and so on. 

Click OK to return to the HIFREQ (System) screen. 

With the conductor type, coating type and energization type specified, the conductor network can 

now be defined and energized in the Main-Ground Conductors block in the HIFREQ (System) 

screen. The characteristics of conductors and their energizations are attributed by selecting the 

appropriate code (pointer) number in the data entry field under Main-Ground Conductors. Note 

that you must scroll the window horizontally to access all of the data entry fields. 

There is a very large number of conductors in this example and it would not be practical (for a 

simple tutorial) to enter all of them manually. We will instead illustrate the use of the Import feature 

and import the conductor data directly from HI_02A.F05, which is available in your working 

directory. (This feature can be very useful if you intend to import command mode HIFREQ input 

files in the Input mode since most of the work in doing this is spent entering the conductor data.) 

Click on the Import button, select Append Conductors and browse to the input file HI_02A.F05. 

Click OK. All conductor data in HI_02A.F05 are entered after the last non-empty row in the Main-

Ground Conductors block. 
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For example, a 800 m long Phase conductor C in Figure 2.1(a), which extends from Ys = -400.0 m to 

Yp = + 400.0 m and is at 27 m above the earth surface, is defined by C125 in the above screen. The 

radius of 1565 kcmil 36/7 ACSR is 0.0191 m. The coordinates (Xs, Ys, Zs) specify the origin of the 

conductor and (Xp, Yp, Zp) specify its end. The Number of Segments of Phase C is 40. The 

Conductor Type 2 selects the second conductor type for this conductor, i.e., 1565 kcmil 36/7 

ACSR. The Coating Type 0 selects the default coating type, i.e., no coating. The Bus Number 0 

means this conductor is connected to Bus No. 0, i.e., no energization. 

The LEAD (current) type energization of Phase C is carried out by C132, which attaches a 0.5 m 

long conductor at Y = -400.0 m. The conductor is connected to Bus Number 2, which is defined to 

be a lead type energization with current 4300e
-j0 

A (see above). A current of 4300 A is flowing into 

the phase conductor from Ys = -400.5 m towards Yp = -400 m. Note that a completely different 

situation occurs if the Y coordinates of the origin and end of this conductor are interchanged. In this 

case, the program would force the current to be zero at Y = -400.5 m since this point is not 

connected to any other conductors and the result would be that the entire 4300 A would have to leak 

between Y = -400 m and Y = -400.5 m, generating huge potentials and electric fields. 

Using C135, the 303 kV potential on the phase conductor is clamped by applying a GPR type 

energization to a 0.5 m long conductor at Y = 400.0 m. The Bus Number refers to an energization of 

type 5. The GPR energization will, at the same time, absorb all the current flowing in the Phase wire 

C at the conductor end corresponding to Y = 400 m since currents cannot be allowed to leak into the 

air from the end of a conductor. The other phases are energized in a similar way (C124, C131, and 

C-134 for Phase B, C126, C133, and C136 for Phase A). 

Voltage energizations can also be used to energize the transmission line. The VOLTAGE 

energization allows for more realistic modeling at the expense of a little bit more work. In this case, 

we need three VOLTAGE energizations, one for each phase. Furthermore, an impedance, typically a 

resistor, must be attached to each phase to limit the current flow. A resistance of 70.465  (which is 

much larger than the impedance of the wires) will give a current of 4300 A, as before. 

You can examine the configuration of your conductor network easily while you are entering 

conductors. To view the conductor network, click the Show Data button in the HIFREQ (System) 

screen and several buttons (e.g., View from different directions and Animation) will appear. The 

Animation button will rotate the conductor network automatically. Consult the on-line help for more 

detailed instructions on how to view the conductor network in several useful ways. 
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Return to the HIFREQ screen by clicking OK. 

The COMPUTATION module, which is invoked 

by clicking on Computations button in the 

HIFREQ screen, defines the physical quantities 

to be computed, the location of the observation 

points where these quantities are to be computed 

and the frequencies at which the computations are 

to be carried out. Select Profiles in the Specify 

option. 

In this example, the electric and magnetic fields 

and the scalar potential are computed for a single 

frequency (60 Hz). There are 101  81 

observation points, all located at 5 cm above the 

earth’s surface (i.e. at Z = -0.05m, negative Z 

being above the ground in HIFREQ). The points 

start at X = -60 m, Y = 40 m with increments of 

1m in the X direction and -1m in the Y direction. 

To specify those points, first enter the Profiles data as in the above screen, and then click on the 

Surface option button. The data of the following table must then be entered. This instructs the 

program to translate the previously defined profile 80 times by dX = 0, dY = -1m and dZ = 0, 

thereby creating a total of 81 parallel profiles. 

Ns dX dY dZ 

81 0 -1 0 

When the height of the observation point is precisely zero (i.e. the observation point lies at the air-

soil interface), HIFREQ assumes that the point is in the ground for the purpose of calculating the 

electric and magnetic fields. If the fields in the air but close to the air-soil interface are desired, an 

observation profile must be specified at a small height above the ground. This is the reason behind 

the choice of a height of 0.05 m for the observation points. 

You can now return to the HIFREQ screen by clicking OK. At this point, you have completed the 

preparation of the data. From File, click Save. This will a files under the names HI_TUT2A.F05. 

Each file can be reread using the File | Import / Load menu item. The *.F05 files are ASCII files 

you can edit and view at any time. 

Now the file HI_TUT2A is ready to be submitted to the HIFREQ engineering module in the next 

chapter. Click  in the toolbar to go back to the CDEGS startup screen. 

A.1.2 Fault Case 

Only a few changes to the previous input file are needed to produce a model for a fault at the tower. 

The input file corresponding to the fault is available in your CDEGS directory under the name 

HI_02B.F05. 
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To prepare the HIFREQ input file for the fault case, the JobID must first be changed to TUT2B. This 

can be done by entering “TUT2B” in the Current JobID box in the CDEGS main screen. Click the 

HIFREQ button located in the Toolbar. The HIFREQ screen will appear and you are now ready to 

input data. 

The strategy adopted here will be to reload the input file for the Unbalanced Currents Case 

HI_TUT2A.F05 and modify it slightly. If you do not wish to go through these steps, you can import 

all the data from the file HI_02B.F05 that has been prepared for you. 

Importing DATA 

Click on the File | Import/Load menu item. Change the File Name in the dialog box to 

HI_02A.F05 (or HI_02B.F05, according to your preference) then click on the Load button in the 

dialog box. The data described in the next section will be loaded and you will not have to enter it. 

 

It is recommended to use a different Run-Identification (EXAMPLE2 - FAULT, in the HIFREQ 

main screen) for this case in order to avoid confusion. (Click Specify to define this value.) Most of 

the changes are in the SYSTEM module. The energization of the network must be changed 

completely. The new ENERGIZATION data reads: 

Bus Type Magnitude Angle 

1 Lead 430 -120 

2 Lead 430 0 

3 Lead 15000 0 

4 GPR-Pot 303000 -120 

5 GPR-Pot 303000 0 

6 Lead 0 0 

Table A.1 Energizations for the Fault Case 

Furthermore, a new conductor must be introduced to cause a short between Phase A and a shield 

wire. This data should be inserted at the end of the Main-Ground Conductors grid. 

Xs 

(Origin) 

Ys 

(Origin) 

Zs 

(Origin) 

Xp 

(End) 

Yp 

(End) 

Zp 

(End) 

Radius Nseg Cond Coat Bus 

12 0 -31.0 10.0 0 -27 .0191 1 0 0 0 

Table A.2 Fault Conductor 

All other conductors are as before. 

The situation is now as follows. Phases B and C are assumed to be unaffected by the fault. They 

carry a current of 430 Amps and are at 303 kV. To simulate the fault, a current of 15000 Amps is 

injected at the Y = -400m end of Phase A while a current of 0 Amps is injected at the other end. This 

is as shown in Figure A.1. To simulate a fault where current comes in from both sides; one simply 

has to change the first and fourth ENERGIZATIONs accordingly. 
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Figure A.1 Fault Currents 

The earth potentials are of interest here, so the location of the observation points (in the 

COMPUTATIONS module) has to be shifted to the surface of the earth (Z = 0). This is done by 

replacing Zorigin = -0.05 in the Profile block of the Computation screen for HI_02A.F05 by Zorigin = 

0.0. 

You can now return to the HIFREQ screen by clicking OK. At this point, you have completed the 

preparation of the data. From File, click Save. This will a file under the names HI_TUT2B.F05. This 

file can be reread using the File | Import/Load menu item. The *.F05 files are ASCII files you can 

edit and view at any time. 

Now the file HI_TUT2B.F05 is ready to be submitted to the HIFREQ engineering module in the 

next chapter. 

If you are a licensee of the CDEGS software you will now be able to proceed to Chapter 4. Users of 

the demo software are not able to process the input file, but are able to peruse all output files that are 

already available. Therefore read Chapter 4 for reference only. Any attempt to start the engineering 

modules will result in a message stating that the Engineering module is not active. 
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COMMAND INPUT MODE 
Any of the interfaces listed below or a text editor can be used to prepare the input data. The 

Windows input modes convert the results of an input session to a Command Mode compatible 

ASCII input file which can be edited at any time. This document describes the Windows session 

mode detail. 

 The Windows Input mode. 

 The Command Mode. 

 Plain Text Editor Mode.  

Printout B.1 shows part of the HIFREQ file that describes the problem being modeled for case (i) 

above. The complete file is available in your CDEGS directory under the name HI_02A.F05. The 

input file for case (ii) is also available in your CDEGS directory (under the name HI_02B.F05). 

Similar files can be prepared more easily by following the information contained in the template 

shown in Figure B.1. 

These HIFREQ files can be edited directly by an experienced user or are automatically produced 

when using one of the above-listed input interface modules. The dialogue, character-based menu 

and Windows input modes convert the results of an input session to a Command mode compatible 

ASCII input file that can be edited at any time. Similar files can be prepared quite easily by 

following the information contained in the template shown in Figure B.1. 

HIFREQ 

TEXT,GRID,",""A 525 kV transmission tower""" 

TEXT,GRID,"Electromagnetic field distribution near transmission lines." 

TEXT,GRID,"LEAD and GPR energization." 

TEXT,GRID,"For 57th American Power Conference, Chicago 1995." 

TEXT,GRID,"Tower and 12 by 30 m fence. 7% Unbalanced Currents." 

COMPONENTS 

  TEMPLATES 

    GRID, SIMPLE, -1, 0, 0, 0, .007, 3, 3 

      CGRIDCOORD, -8, 392, .5, 8, 392, .5, -8, 408, .5 

      SPACING, LINEAR 

    GRID, SIMPLE, -1, 0, 0, 0, .007, 3, 3 

      CGRIDCOORD, -8, -408, .5, 8, -408, .5, -8, -392, .5 

      SPACING, LINEAR 

  GROUP, , 0, 0 

 

 

 

  GROUP, , 0, 0 

OPTIONS 

  RUN-IDENTIFI, Example2 - UNB 

  UNITS, METRIC 

  PRINTOUT, DETAILED 

! 

! 
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! 

SYSTEM 

! 

  ENERGIZATION, LEAD,-2314.72,-3564.35,,,,,,Lead-PhaseB 

  ENERGIZATION, LEAD,4300,0,,,,,,Lead-PhaseC 

  ENERGIZATION, LEAD,-1939.24,3498.48,,,,,,Lead-PhaseA 

  ENERGIZATION, GPR-POTENTIAL,-153481,-255436,,,,,,GPR-PhaseB 

  ENERGIZATION, GPR-POTENTIAL,303000,0,,,,,,GPR-PhaseC 

  ENERGIZATION, GPR-POTENTIAL,-148500,257210,,,,,,GPR-PhaseA 

  CHARACTERISTICS 

    CONDUCTOR-TYPE,DEFAULT,1,1,0,0,0,0,0,0,Default Conductor 

    CONDUCTOR-TYPE,Computed,12,250,0,0,0,0,0,0,Steel 

    CONDUCTOR-TYPE,Computed,1.67,1,0,0,0,0,0,0,Aluminum 

    CONDUCTOR-TYPE,Computed,12,250,.01,0,0,0,0,0,Fence Post 

 

  NETWORK 

    MAIN-GROUND 

      CONDUCTOR,-1, 1, 0, 0,-4.5,-4.5,-10,0,-4.5,-10,.015, 2,1 

      CONDUCTOR,-1, 1, 0, 0,0,-4.5,-10,4.5,-4.5,-10,.015, 2,1 

      CONDUCTOR,-1, 1, 0, 0,4.5,-4.5,-10,4.5,4.5,-10,.015, 2,1 

      CONDUCTOR,-1, 1, 0, 0,4.5,4.5,-10,0,4.5,-10,.015, 2,1 

 

 

 

      CONDUCTOR,-1, 3, 0, 0,-16,3,0,-16,3,1,.02, 2,35 

      CONDUCTOR,-1, 3, 0, 0,-16,3,-1.5,-16,6,-1.5,.02, 2,35 

      CONDUCTOR,-1, 1, 0, 0,-16,3,0,-16,6,-1.5,.003, 1,35 

      CONDUCTOR,-1, 1, 0, 0,-16,3,-1.5,-16,6,0,.003, 1,35 

COMPUTATIONS 

  DETERMINE 

    GPR, ON 

    POTENTIAL-SCALAR, ON 

    ELECTRIC, ON 

    MAGNETIC, ON 

    VECTOR-POTENTIAL, ON 

    GRADIENT-SCALAR, ON 

    CURRENTS, COMPUTED 

  OBSERVATION 

    PROFILE, 101,-60,40,-.05,1,0,0,0 

      SURFACE, 81,0,-1,0,0 

  FREQUENCY, 0 

    INDIVIDUAL, 60 

 

SOIL-TYPE,LIMITED-LAYE 

  UNIFORM, AIR,1E+18,1,1 

  UNIFORM, EARTH,100,1,1 

ENDPROGRAM 

 

Printout B.1 HIFREQ Input File HI_TUT2A.F05 for the Unbalance Case (Partial) 
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Figure B.1 HIFREQ Input File Template 
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